danger/u/
E: Sub-process /usr/bin/dpkg returned an error code (1)

| >sudo apt-get clean && sudo apt-get update
>sudo apt-get install -f
dpkg: error processing package linux-image-4.15.0-76-generic (--remove):
installed linux-image-4.15.0-76-generic package post-removal script subprocess returned error exit status 1
Errors were encountered while processing:
linux-image-4.15.0-45-generic
linux-image-4.15.0-76-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

what


| >sudo dpkg --configure -a
Setting up grub-pc (2.02-2ubuntu8.14) ...
/var/lib/dpkg/info/grub-pc.config: 44: /etc/default/grub: Syntax error: EOF in backquote substitution
dpkg: error processing package grub-pc (--configure):
installed grub-pc package post-installation script subprocess returned error exit status 2
Errors were encountered while processing:
grub-pc

??????????


| >sudo apt purge linux-image-4.15.0-76-generic linux-image-4.15.0-45-generic
...

dpkg: error processing package linux-image-4.15.0-76-generic (--remove):
installed linux-image-4.15.0-76-generic package post-removal script subprocess returned error exit status 1
Errors were encountered while processing:
linux-image-4.15.0-45-generic
linux-image-4.15.0-76-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)


| >sudo apt upgrade
...
Some packages couldn't be installed. This may mean that you've
requested an impossible situation or if you're using the unstable
distribution that some required packages haven't yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
linux-image-4.15.0-45-generic : Depends: linux-modules-4.15.0-45-generic but it is not going to be installed
E: Broken packages


| >sudo apt-get autoremove
...
Errors were encountered while processing:
linux-image-4.15.0-45-generic
linux-image-4.15.0-76-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)


| >sudo apt install steam
...
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 2
dpkg: error processing package linux-image-4.15.0-76-generic (--remove):
installed linux-image-4.15.0-76-generic package post-removal script subprocess returned error exit status 1
Errors were encountered while processing:
linux-image-4.15.0-45-generic
linux-image-4.15.0-76-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)


| I guess my question is why clean, why -f and why apt-get instead of apt, but also

Shits fucked yo


| I guess my question is why clean, why -f and why apt-get instead of apt, but also

Shits fucked yo


| >>625257 >>625258
>Shits fucked yo
ok doubleposter what do i do


| should i purge grub-pc ???


| i just removed grub-pc

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
linux-image-4.15.0-45-generic : Depends: linux-modules-4.15.0-45-generic but it is not going to be installed


| Recommends: grub-pc or
grub-efi-amd64 or
grub-efi-ia32 or
grub but it is not installable or
lilo but it is not going to be installed
E: Broken packages


| A single quote. (triple quote)

https://askubuntu.com/questions/686723/half-installed-kernel-cant-install-uninstall-anything/686734#686734


| thread can be closed

Total number of posts: 14, last modified on: Tue Jan 1 00:00:00 1581201636

This thread is closed.