danger/u/
trynna install awoo; ey'm a dumbass

| Reposting from /test/ because I am dumb.
I installed this awoo textboard thingymajig on my webserver, but I dunno how to actually get it running. I tried
# ruby generic_test.rb
Which threw up some errors:
http://0x0.st/zwJj.txt
Wat do?
t. hasn't ever installed any sort of web software before plsbullyme
Sorry if I'm coming off as a spoonfeed seeker.


| >actually using the test
if you're not sudo make installing and just fiddling from there, what are you even doing
that said, the problem just seems to be in the test itself. have you actually tried, y'know, checking if post-install, the site itself is running fine on your localhost?


| Did you install the dependencies?


| did you type >awoo 56709
into the console?


| >>600920
>not sudo make installing and fiddling from there
>implying that's not what I'm doing
I don't even know where the index page is supposed to be.
>>600921
Fairly sure, the errors in the paste are
>expected false to be truthy (no fucking clue there)
>JS unexpected token at [nginx default page source text]
>another "expected false to be truthy"
So none of them seem related to dependencies
>>600935
AWOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO
>awoo: command not found


| >>601116
>I don't even know where the index page is supposed to be.
src/views/index.erb
>JS unexpected token at [nginx default page source text]
that seems more like an optional thing rather than a mandatory one. like "hey this kinda sux and you should probably change it but it's fine lol"

>font-family: sans-serif,helvetica;
what are you doing nginx


| >>601294
When I set that as the index on nginx, opening it in a browser tries to download it as a .BIN file. Am I supposed to install something else to allow nginx to parse ruby applications? Fukkin hell webdev is complicated.


| >>601411 probably use nginx as a reverse proxy and not point it to the dir


| Usually web apps run their own web server and you just proxy the request to it, gogs/gitea does this and others. But I'm not familiar with awoo so

Total number of posts: 9, last modified on: Sat Jan 1 00:00:00 1570676039

This thread is closed.