danger/u/
HEEEEEELP

| my kubuntu went fucked up. i can't even see what i'm typing. i was chilling and all of a sudden 'Could not enter folder /home/user.' i can't open system settings - my permissions are ALL GONE - i can't open new tabs on the konsole - my internet cuts off randomly - i can't fucking see what i type help i'm afraid to reboot i've tried sudo apt update sudo apt upgrade and it didn't help what do i do


| i think all of my permissions have been screwed. i can't open ~/.config/konsolerc or cwhatever it's called. i have lost all root privileged and i tried to set permissions for my home / user / .config folders but it did nothing. i can't start most programs


| i have no idea why but the contents of my /home folder are now in my root folder. what the fuck


| my /home folder has a lock on the icon


| "my /home folder has a lock on the iconConfiguration file "/home/user/.config/kio_applicationsrc" not writable.
Please contact your system administrator."


| ls -l /home/total 4drwx------ 58 root root 4096 Mar 1 15:50 user


| i can't believe it. i did chown user:user /home/ and now it shows me that my home folder is completely empty. why is all my stuff in root


| okay the little lock has gone away but what the fuck
turns out all my stuff was in root even my browser that's why there were permissions problems because it all was in root wtf wtf wtf


| i must have done a bad mv ???


| cannot move directory directory not empty... how do i move directory...


| HOW DO I GET THEM OUT OF ROOT AND INTO HOME I CAN'T MOVE THEM


| even when i chown Access denied to /home/user/Documents. i can't fucking move it.


| i just did chown user:user /home/user/ and it worked. my folders popped up again. but i didn't copy yet... why are they here? i din't move anything yet

i still can't see what i'm typing
captcha: swine ugh arab


| i did chown but it stays owned by root. is .config untouchable? i need to set permissions to writable ?
captcha junta atlas cocks


| i alternated between chown and deleting the folders in my root which were apparently emprty. i guess it really was just a permission change. what the fuck? is this a virus? will i get shafter once i reboot?


| the messages aren't popping up anymore and my konsole can open new tabs. don't just close this thread, delete it from everything.


| install gentoo


| Be careful with changing ownership and especially permissions recursively, even in your homedir. There are hidden config files that have restricted permissions for good reasons, such as ~/.ssh or ~/.gnupg
Maybe create a new homedir for user at /home/user owned by user:user and copy your important files from the broken homedir into the new one.
Also consider to switch from kubuntu to kde neon. It uses an ubuntu lts as basis while it offers well maintained and latest kde packages.

Total number of posts: 18, last modified on: Mon Jan 1 00:00:00 1551515657

This thread is closed.